Start a new topic

Question On Lab 6.1

Hi,

I normally work with MVC, and the labs are working with WebForms,so I'm a bit rusty. I added the repeater control in Lab B on Lab 6.1

I noticed that in Visual Studio, I wasn't offered the option to Create a new Method in SelectMethod. (Visual Studio 2015 Community)

The solution acted at times that it wouldn't recognize the method names. I added rpSubnavigation_GetData. I added the code in the code behind and in the SelectMethod Parameter. I was getting some error that the method couldn't be found or it was a duplicate? Very strange. I tried cleaning the solution and even removing the Microsoft Framework temporary internet files.

I finally tried creating a new method rpSubnavigation_GetData2. At some point it recognized the method. What's interesting, is that I tried renaming the method name back to rpSubnavigation_GetData. I then started getting message that it couldn't find or there was a duplicate rpSubnavigation_GetData2? 

I tried cleaning the solution, rebuilding and deploying and checking the Pet List in Sitecore Experience Manager. I still get the Yellow Screen of the error, so I have renamed the method back to rpSubnavigation_GetData2

I can change the name back, and it compiles and seems to work. The Item name is printed in the control, but I'm missing the menu item at the top, like in the image in the lab.

Do you know what is causing the error if I try renaming the method name. Is this something that's happening in Sitecore, Sitecore Rocks, or visual studio? Is this a known issue?



Thanks,

Mike Sustrick
Login to post a comment